Click or drag to resize

IndexPair Structure

Represents two indices: I and J.

Namespace:  Rhino
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
[SerializableAttribute]
public struct IndexPair : IList<int>, 
	ICollection<int>, IEnumerable<int>, IEnumerable, IReadOnlyList<int>, 
	IReadOnlyCollection<int>

The IndexPair type exposes the following members.

Constructors
  NameDescription
Public methodIndexPair
Initializes a new instance of IndexPair with two indices.
Top
Properties
  NameDescription
Public propertyCount
Returns the amount of elements in this pair of indices, which is always 2.
Public propertyI
Gets or sets the first, I index.
Public propertyItem
Gets or sets a particular index of this structure.
Remarks
Only 0 and 1 are valid indices.
Public propertyJ
Gets or sets the second, J index.
Top
Methods
  NameDescription
Public methodContains
Determines whether the IndexPair contains a specific value.
Public methodCopyTo
Copies the elements of the IndexPair to an Array, starting at a particular Array index.
Public methodGetEnumerator
Gets an enumerator that goes over I and J, in this order.
Public methodIndexOf
Determines the index of a specific item in IndexPair.
Top
See Also