Click or drag to resize

IndexPairCopyTo Method

Copies the elements of the IndexPair to an Array, starting at a particular Array index.

Namespace:  Rhino
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 6.0
Syntax
public void CopyTo(
	int[] array,
	int arrayIndex
)

Parameters

array
Type: SystemInt32
The one-dimensional Array that is the destination of the elements copied from IndexPair. The Array must have zero-based indexing.
arrayIndex
Type: SystemInt32
The zero-based index in array at which copying begins.

Implements

ICollectionTCopyTo(T, Int32)
Exceptions
ExceptionCondition
ArgumentNullExceptionarray is null.
ArgumentOutOfRangeExceptionarrayIndex is less than 0 or arrayIndex is greater than or equals the length of array minus 2.
ArgumentExceptionThe length of the array is less than 2.
See Also