Click or drag to resize

MeshVertexStatusList Class

Provides access to status information relative to components of a mesh.
Inheritance Hierarchy
SystemObject
  Rhino.Geometry.CollectionsMeshVertexStatusList

Namespace:  Rhino.Geometry.Collections
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class MeshVertexStatusList : IResizableList<bool>, 
	IList<bool>, ICollection<bool>, IEnumerable<bool>, 
	IEnumerable, IList, ICollection, IReadOnlyList<bool>, IReadOnlyCollection<bool>

The MeshVertexStatusList type exposes the following members.

Properties
  NameDescription
Public propertyCapacity
Gets or sets the total number of hidden vertex information the internal data structure can hold without resizing.
Public propertyCount
Gets or sets the number of hidden vertices. For this to be a valid part of a mesh, this count should be the same as the one of mesh vertices.
Public propertyHiddenCount
Gets a value indicating how many vertices have been set to hidden.
Public propertyItem
Gets or sets the hidden value at the given index. The index must be valid or an IndexOutOfRangeException will be thrown.
Top
Methods
  NameDescription
Public methodAdd
Adds a new flag at the end of the list.
Public methodAddRange
Appends an array, a list or any enumerable of flags to the end of the list.
Public methodClear
Clears the hidden vertex list on the mesh. This results in a fully visible mesh.
Public methodContains
Determines if some vertices are hidden or some are shown.
Public methodCopyTo
Copies to an array, starting at an index.
Public methodDestroy
Releases all memory allocated to store hidden vertices. The list capacity will be 0 after this call.

Vertices will be immediately considered visible.

Subsequent calls can add new items.

Public methodGetEnumerator
Gets an enumerator that yields all flags in this collection.
Top
See Also