BrepTrimList Class |
Namespace: Rhino.Geometry.Collections
The BrepTrimList type exposes the following members.
Name | Description | |
---|---|---|
![]() | Count |
Gets the number of brep trims.
|
![]() | Item |
Gets the BrepTrim at the given index.
The index must be valid or an IndexOutOfRangeException will be thrown.
|
Name | Description | |
---|---|---|
![]() | Add(Int32) |
Add a new trim that will be part of an inner, outer, or slit loop
to the brep.
|
![]() | Add(Boolean, BrepEdge, Int32) |
Add a new trim that will be part of an inner, outer, or slit loop
to the brep
|
![]() | Add(Boolean, BrepLoop, Int32) |
Add a new trim that will be part of an inner, outer, or slit loop
to the brep
|
![]() | Add(BrepEdge, Boolean, BrepLoop, Int32) |
Add a new trim that will be part of an inner, outer, or slit loop
to the brep.
|
![]() | AddCurveOnFace | Add a new curve on face to the brep |
![]() | AddSingularTrim | Add a new singular trim to the brep. |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.) |
![]() | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.) |
![]() | GetEnumerator |
Gets an enumerator that visits all edges.
|
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object.) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object.) |
![]() | MatchEnds |
Matches the endpoints of all trims in the Brep.
|
![]() | MatchEnds(BrepLoop) |
Match the endpoints of all trims in a loop.
|
![]() | MatchEnds(Int32) |
Match the endpoints of a trim to the next and previous trim.
|
![]() | MatchEnds(BrepTrim, BrepTrim) |
Match the end of a trim to the start of the next trim.
|
![]() | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object.) |