Click or drag to resize

BrepTrimListAdd Method (BrepEdge, Boolean, BrepLoop, Int32)

Add a new trim that will be part of an inner, outer, or slit loop to the brep.

Namespace:  Rhino.Geometry.Collections
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.4
Syntax
public BrepTrim Add(
	BrepEdge edge,
	bool rev3d,
	BrepLoop loop,
	int curve2dIndex
)

Parameters

edge
Type: Rhino.GeometryBrepEdge
3d edge associated with this trim
rev3d
Type: SystemBoolean
true if the edge and trim have opposite directions
loop
Type: Rhino.GeometryBrepLoop
trim is appended to this loop
curve2dIndex
Type: SystemInt32
index of 2d trimming curve

Return Value

Type: BrepTrim
new trim
See Also