Click or drag to resize

BrepTrimList Methods

The BrepTrimList type exposes the following members.

Methods
  NameDescription
Public methodAdd(Int32)
Add a new trim that will be part of an inner, outer, or slit loop to the brep.
Public methodAdd(Boolean, BrepEdge, Int32)
Add a new trim that will be part of an inner, outer, or slit loop to the brep
Public methodAdd(Boolean, BrepLoop, Int32)
Add a new trim that will be part of an inner, outer, or slit loop to the brep
Public methodAdd(BrepEdge, Boolean, BrepLoop, Int32)
Add a new trim that will be part of an inner, outer, or slit loop to the brep.
Public methodAddCurveOnFace
Add a new curve on face to the brep
Public methodAddSingularTrim
Add a new singular trim to the brep.
Public methodGetEnumerator
Gets an enumerator that visits all edges.
Public methodMatchEnds
Matches the endpoints of all trims in the Brep.
Public methodMatchEnds(BrepLoop)
Match the endpoints of all trims in a loop.
Public methodMatchEnds(Int32)
Match the endpoints of a trim to the next and previous trim.
Public methodMatchEnds(BrepTrim, BrepTrim)
Match the end of a trim to the start of the next trim.
Top
See Also