Click or drag to resize

NamedViewTable Class

All named views in a rhino document.
Inheritance Hierarchy
SystemObject
  Rhino.DocObjects.TablesNamedViewTable

Namespace:  Rhino.DocObjects.Tables
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public sealed class NamedViewTable : IEnumerable<ViewInfo>, 
	IEnumerable

The NamedViewTable type exposes the following members.

Properties
  NameDescription
Public propertyCount
Number of named views in the table.
Public propertyDocument
Document that owns this table.
Public propertyItem
Conceptually, the named view table is an array of ViewInfo and their associated names. The indexing operator ([] in C#) can be used to get individual ViewInfo items.
Public propertySelection
Returns the current selection in the Named Views panel. If more than one such panel is open, it will return the selection in the most recently opened panel.
Top
Methods
  NameDescription
Public methodAdd(ViewInfo)
Public methodCode exampleAdd(String, Guid)
Adds named view to document which is based on an existing viewport.
Public methodDelete(Int32)
Remove named view from the document.
Public methodDelete(String)
Remove named view from the document.
Public methodFindByName
Finds a named view.
Public methodGetEnumerator
Public methodRename(Int32, String)
Renames a named view.
Public methodRename(String, String)
Renames a named view.
Public methodRestore(Int32, RhinoViewport)
Sets the MainViewport of a standard RhinoView to a named views settings
Public methodRestore(Int32, RhinoView, Boolean) Obsolete.
Public methodRestore(Int32, RhinoViewport, Boolean) Obsolete.
Public methodRestoreAnimated(Int32, RhinoView, Boolean) Obsolete.
Public methodRestoreAnimated(Int32, RhinoViewport, Boolean) Obsolete.
Public methodRestoreAnimated(Int32, RhinoView, Boolean, Int32, Int32) Obsolete.
Public methodRestoreAnimated(Int32, RhinoViewport, Boolean, Int32, Int32) Obsolete.
Public methodRestoreAnimatedConstantSpeed
Public methodRestoreAnimatedConstantTime
Public methodRestoreWithAspectRatio
Top
See Also