Click or drag to resize

NamedViewTable Methods

The NamedViewTable type exposes the following members.

Methods
  NameDescription
Public methodAdd(ViewInfo)
Public methodCode exampleAdd(String, Guid)
Adds named view to document which is based on an existing viewport.
Public methodDelete(Int32)
Remove named view from the document.
Public methodDelete(String)
Remove named view from the document.
Public methodFindByName
Finds a named view.
Public methodGetEnumerator
Public methodRename(Int32, String)
Renames a named view.
Public methodRename(String, String)
Renames a named view.
Public methodRestore(Int32, RhinoViewport)
Sets the MainViewport of a standard RhinoView to a named views settings
Public methodRestore(Int32, RhinoView, Boolean) Obsolete.
Public methodRestore(Int32, RhinoViewport, Boolean) Obsolete.
Public methodRestoreAnimated(Int32, RhinoView, Boolean) Obsolete.
Public methodRestoreAnimated(Int32, RhinoViewport, Boolean) Obsolete.
Public methodRestoreAnimated(Int32, RhinoView, Boolean, Int32, Int32) Obsolete.
Public methodRestoreAnimated(Int32, RhinoViewport, Boolean, Int32, Int32) Obsolete.
Public methodRestoreAnimatedConstantSpeed
Public methodRestoreAnimatedConstantTime
Public methodRestoreWithAspectRatio
Top
See Also