BitmapTable Class |
Namespace: Rhino.DocObjects.Tables
The BitmapTable type exposes the following members.
Name | Description | |
---|---|---|
ComponentType |
Returns Image.
(Overrides CommonComponentTableTComponentType.) | |
Count |
Returns the count of all items, including deleted ones.
(Inherited from CommonComponentTableT.) | |
Document | Document that owns this table. (Inherited from RhinoDocCommonTableT.) | |
Item |
Conceptually, the bitmap table is an array of bitmaps. The operator[]
can be used to get individual bitmaps.
|
Name | Description | |
---|---|---|
AddBitmap | Adds a new bitmap with specified name to the bitmap table. | |
Clear |
Marks all items as deleted.
(Inherited from CommonComponentTableT.) | |
Delete |
Removes the bitmap from the table.
(Overrides CommonComponentTableTDelete(T).) | |
DeleteBitmap | Deletes a bitmap. | |
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.) | |
ExportToFile | Writes a bitmap to a file. | |
ExportToFiles | Exports all the bitmaps in the table to files. | |
Find |
This function first attempts to find the file with "name" on the disk.
If it does find it, "fileName" is set to the full path of the file and
the BitmapEntry returned will be null, even if there was a BitmapEntry
with "name" in the bitmap table.
If the function cannot find the file on the disk, it searches the bitmap
table. If it finds it, the returned BitmapEntry entry will be the entry
in the table with that name.
Additionally, if "createFile" is true, and an entry is found, the file
will be written to the disk and it's full path will be contained in "fileName".
| |
FindId |
Uses the guid to find a model component. Deleted objects cannot be found by id.
The guid is the value that is stored in the .Id property.
In a single document, no two active objects have the same guid. If an object is
replaced with a new object, then the guid persists. For example, if the _Move command
moves an object, then the moved object inherits its guid from the starting object.
If the Copy command copies an object, then the copy gets a new guid. This guid persists
through file saving/opening operations. This function will not find grip objects.
(Inherited from CommonComponentTableT.) | |
FindIndex |
Retrieves a BitmapEntry object based on Index. This search type of search is discouraged.
We are moving towards using only IDs for all tables.
| |
GetEnumerator |
Returns the enumerator that yields all items.
(Inherited from CommonComponentTableT.) | |
GetHashCode | Serves as the default hash function. (Inherited from Object.) | |
GetType | Gets the Type of the current instance. (Inherited from Object.) | |
ToString | Returns a string that represents the current object. (Inherited from Object.) |