Click or drag to resize

BitmapTable Methods

The BitmapTable type exposes the following members.

Methods
  NameDescription
Public methodAddBitmap
Adds a new bitmap with specified name to the bitmap table.
Public methodDelete
Removes the bitmap from the table.
(Overrides CommonComponentTableTDelete(T).)
Public methodDeleteBitmap
Deletes a bitmap.
Public methodExportToFile
Writes a bitmap to a file.
Public methodExportToFiles
Exports all the bitmaps in the table to files.
Public methodFind
This function first attempts to find the file with "name" on the disk. If it does find it, "fileName" is set to the full path of the file and the BitmapEntry returned will be null, even if there was a BitmapEntry with "name" in the bitmap table. If the function cannot find the file on the disk, it searches the bitmap table. If it finds it, the returned BitmapEntry entry will be the entry in the table with that name. Additionally, if "createFile" is true, and an entry is found, the file will be written to the disk and it's full path will be contained in "fileName".
Public methodFindIndex
Retrieves a BitmapEntry object based on Index. This search type of search is discouraged. We are moving towards using only IDs for all tables.
Top
See Also