Click or drag to resize

VisualAnalysisMode Class

Represents a base class for visual analysis modes.

This class is abstract.

Inheritance Hierarchy
SystemObject
  Rhino.DisplayVisualAnalysisMode

Namespace:  Rhino.Display
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public abstract class VisualAnalysisMode

The VisualAnalysisMode type exposes the following members.

Constructors
  NameDescription
Protected methodVisualAnalysisMode
Initializes a new instance of the VisualAnalysisMode class
Top
Properties
  NameDescription
Public propertyId
Gets the visual analysis mode GUID. The Guid is specified with the GuidAttribute applied to the class.
Public propertyName
Gets the name of the analysis mode. It is used by the _What command and the object properties details window to describe the object.
Public propertyStatic memberRhinoCurvatureColorAnalyisModeId
Id for Rhino's built-in curvature color analysis mode. Surface curvature is shown using false color mapping.
Public propertyStatic memberRhinoCurvatureGraphAnalysisModeId
Id for Rhino's built-in curvature graphs analysis mode. Curvature hair is shown on curves and surfaces.
Public propertyStatic memberRhinoDraftAngleAnalysisModeId
Id for Rhino's built-in draft angle analysis mode. Draft angle is displayed using false colors.
Public propertyStatic memberRhinoEdgeAnalysisModeId
Id for Rhino's built-in edge analysis mode. Brep and mesh edges are shown in a selected color.
Public propertyStatic memberRhinoEdgeContinuityAlalysisModeId
Id for Rhino's built-in edge continuity analysis mode.
Public propertyStatic memberRhinoEmapAnalysisModeId
Id for Rhino's built-in emap analysis mode. An environment map is shown on surfaces and meshes.
Public propertyStatic memberRhinoThicknessAnalysisModeId
Id for Rhino's built-in thickness analysis mode.
Public propertyStatic memberRhinoZebraStripeAnalysisModeId
Id for Rhino's built-in zebra stripe analysis mode. Zebra stripes are shown on surfaces and meshes.
Public propertyShowIsoCurves
Gets true if this visual analysis mode will show isocuves on shaded surface objects. Often a mode's user interface will provide a way to change this setting.

The default is false.

Public propertyStyle
Gets the visual analysis mode style.
Top
Methods
  NameDescription
Public methodStatic memberAdjustAnalysisMeshes
Interactively adjusts surface analysis meshes of objects using a Rhino built-in analysis mode.
Protected methodDrawBrepObject
Draws one brep. Override this method to add your custom behavior.

The default implementation does nothing.

Protected methodDrawCurveObject
If Style==Wireframe, then the default decomposes the curve object into nurbs curve segments and calls the virtual DrawNurbsCurve for each segment.
Protected methodDrawMesh
Draws a mesh.

The default implementation does nothing.

Protected methodDrawMeshObject
Draws one mesh. Override this method to add your custom behavior.

The default implementation does nothing.

Protected methodDrawNurbsCurve
Draws a NURBS curve. This is a good function to override for analysis modes like curvature hair display.

The default implementation does nothing.

Protected methodDrawNurbsSurface
Draws a NURBS surface. This is a good function to override to display object-related meshes.

The default implementation does nothing.

Protected methodDrawPointCloudObject
Draws one point cloud. Override this method to add your custom behavior.

The default implementation does nothing.

Protected methodDrawPointObject
Draws one point. Override this method to add your custom behavior.

The default implementation does nothing.

Public methodEnableUserInterface
Turns the analysis mode's user interface on and off. For Rhino's built in modes this opens or closes the modeless dialog that controls the analysis mode's display settings.
Public methodStatic memberFind(Guid)
Finds a visual analysis mode by guid.
Public methodStatic memberFind(Type)
Finds a visual analysis mode by type.
Public methodObjectSupportsAnalysisMode
Gets a value indicating if this visual analysis mode can be used on a given Rhino object.
Public methodStatic memberRegister
Registers a custom visual analysis mode for use in Rhino. It is OK to call register multiple times for a single custom analysis mode type, since subsequent register calls will notice that the type has already been registered.
Protected methodSetUpDisplayAttributes
If an analysis mode needs to modify display attributes, this is the place to do it. In particular, Style==Texture, then this function must be overridden.
Protected methodUpdateVertexColors
If Style==falseColor, then this virtual function must be overridden. Rhino calls this function when it is time for to set the false colors on the analysis mesh vertices. For breps, there is one mesh per face. For mesh objects there is a single mesh.
Top
See Also