Click or drag to resize

VisualAnalysisMode Properties

The VisualAnalysisMode type exposes the following members.

Properties
  NameDescription
Public propertyId
Gets the visual analysis mode GUID. The Guid is specified with the GuidAttribute applied to the class.
Public propertyName
Gets the name of the analysis mode. It is used by the _What command and the object properties details window to describe the object.
Public propertyStatic memberRhinoCurvatureColorAnalyisModeId
Id for Rhino's built-in curvature color analysis mode. Surface curvature is shown using false color mapping.
Public propertyStatic memberRhinoCurvatureGraphAnalysisModeId
Id for Rhino's built-in curvature graphs analysis mode. Curvature hair is shown on curves and surfaces.
Public propertyStatic memberRhinoDraftAngleAnalysisModeId
Id for Rhino's built-in draft angle analysis mode. Draft angle is displayed using false colors.
Public propertyStatic memberRhinoEdgeAnalysisModeId
Id for Rhino's built-in edge analysis mode. Brep and mesh edges are shown in a selected color.
Public propertyStatic memberRhinoEdgeContinuityAlalysisModeId
Id for Rhino's built-in edge continuity analysis mode.
Public propertyStatic memberRhinoEmapAnalysisModeId
Id for Rhino's built-in emap analysis mode. An environment map is shown on surfaces and meshes.
Public propertyStatic memberRhinoThicknessAnalysisModeId
Id for Rhino's built-in thickness analysis mode.
Public propertyStatic memberRhinoZebraStripeAnalysisModeId
Id for Rhino's built-in zebra stripe analysis mode. Zebra stripes are shown on surfaces and meshes.
Public propertyShowIsoCurves
Gets true if this visual analysis mode will show isocuves on shaded surface objects. Often a mode's user interface will provide a way to change this setting.

The default is false.

Public propertyStyle
Gets the visual analysis mode style.
Top
See Also