Click or drag to resize

VisualAnalysisMode Methods

The VisualAnalysisMode type exposes the following members.

Methods
  NameDescription
Public methodStatic memberAdjustAnalysisMeshes
Interactively adjusts surface analysis meshes of objects using a Rhino built-in analysis mode.
Protected methodDrawBrepObject
Draws one brep. Override this method to add your custom behavior.

The default implementation does nothing.

Protected methodDrawCurveObject
If Style==Wireframe, then the default decomposes the curve object into nurbs curve segments and calls the virtual DrawNurbsCurve for each segment.
Protected methodDrawMesh
Draws a mesh.

The default implementation does nothing.

Protected methodDrawMeshObject
Draws one mesh. Override this method to add your custom behavior.

The default implementation does nothing.

Protected methodDrawNurbsCurve
Draws a NURBS curve. This is a good function to override for analysis modes like curvature hair display.

The default implementation does nothing.

Protected methodDrawNurbsSurface
Draws a NURBS surface. This is a good function to override to display object-related meshes.

The default implementation does nothing.

Protected methodDrawPointCloudObject
Draws one point cloud. Override this method to add your custom behavior.

The default implementation does nothing.

Protected methodDrawPointObject
Draws one point. Override this method to add your custom behavior.

The default implementation does nothing.

Public methodEnableUserInterface
Turns the analysis mode's user interface on and off. For Rhino's built in modes this opens or closes the modeless dialog that controls the analysis mode's display settings.
Public methodStatic memberFind(Guid)
Finds a visual analysis mode by guid.
Public methodStatic memberFind(Type)
Finds a visual analysis mode by type.
Public methodObjectSupportsAnalysisMode
Gets a value indicating if this visual analysis mode can be used on a given Rhino object.
Public methodStatic memberRegister
Registers a custom visual analysis mode for use in Rhino. It is OK to call register multiple times for a single custom analysis mode type, since subsequent register calls will notice that the type has already been registered.
Protected methodSetUpDisplayAttributes
If an analysis mode needs to modify display attributes, this is the place to do it. In particular, Style==Texture, then this function must be overridden.
Protected methodUpdateVertexColors
If Style==falseColor, then this virtual function must be overridden. Rhino calls this function when it is time for to set the false colors on the analysis mesh vertices. For breps, there is one mesh per face. For mesh objects there is a single mesh.
Top
See Also