Click or drag to resize

VisualAnalysisModeRegister Method

Registers a custom visual analysis mode for use in Rhino. It is OK to call register multiple times for a single custom analysis mode type, since subsequent register calls will notice that the type has already been registered.

Namespace:  Rhino.Display
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public static VisualAnalysisMode Register(
	Type customAnalysisModeType
)

Parameters

customAnalysisModeType
Type: SystemType
Must be a type that is a subclass of VisualAnalysisMode.

Return Value

Type: VisualAnalysisMode
An instance of registered analysis mode on success.
See Also