Click or drag to resize

ViewCaptureSettings Class

Holds information required to generate high resolution output of a RhinoViewport. This is used for generating paper prints or image files
Inheritance Hierarchy
SystemObject
  Rhino.DisplayViewCaptureSettings

Namespace:  Rhino.Display
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class ViewCaptureSettings : IDisposable

The ViewCaptureSettings type exposes the following members.

Constructors
Properties
  NameDescription
Public propertyApplyDisplayModeThicknessScales
Should curves and edges have their thicknesses scaled based the on the display mode settings for a view being captured (default is false)
Public propertyArrowheadSizeMillimeters
Arrowhead size in millimeters.
Public propertyCropRectangle
Actual area of output rectangle that view capture is sent to.
Public propertyDefaultPrintWidthMillimeters
Line thickness, in millimeters, used to print objects with no defined thickness.
Public propertyDocument
Public propertyDrawAxis
Public propertyDrawBackground
Public propertyDrawBackgroundBitmap
Public propertyDrawClippingPlanes
Public propertyDrawGrid
Public propertyDrawLights
Public propertyDrawLockedObjects
Public propertyDrawMargins
Public propertyDrawRectangle
Rectangle where drawing is confined to on MediaSize
Public propertyDrawSelectedObjectsOnly
Public propertyDrawWallpaper
Public propertyFooterText
Text drawn at the bottom of the output
Public propertyHeaderText
Text drawn at the top of the output
Public propertyHorizontalScale
Horizontal stretch to be applied to output. Useful for calibrating printers
Public propertyIsScaleToFit
Returns true if the model has been scaled to fit.
Public propertyIsValid
Public propertyLinetypeWidthUnitsArePageLengths
Public propertyMatchLinetypePatternDefinition
Default is true. Linetype scales are normally generated right before printing/view capture in order to get linetypes to print to the same lengths as defined. If false, the linetypes are not scaled and the current pattern lengths as seen on the screen as used.
Public propertyMediaSize
Total size of the image or page in dots
Public propertyModelScaleType
Public propertyOffsetAnchor
Public propertyOutputColor
Public propertyPointSizeMillimeters
Size of point objects in millimeters. if scale <= 0 the size is minimized so points are always drawn as small as possible
Public propertyRasterMode
Public propertyResolution
Capture "density" in dots per inch.
Public propertyTextDotPointSize
Font point size use for printing text dots. The default value is 10.0.
Public propertyUsePrintWidths
Public propertyVerticalScale
Vertical stretch to be applied to output. Useful for calibrating printers
Public propertyViewArea
How the RhinoViewport is mapped to the output rectangle
Public propertyWireThicknessScale
Scaling factor to apply to object print widths (typically 1.0). This is helpful when printing something at 1/2 scale and having all of the curves print 1/2 as thick.
Top
Methods
  NameDescription
Public methodCreatePreviewSettings
Create a ViewCaptureSettings based on this instance, but scaled to fit in a different sized area. Scaling is also performed on dpi. This is primarily used to for capturing images that are shown as print previews
Public methodDispose
Actively reclaims unmanaged resources that this instance uses.
Public methodEquals(ViewCaptureSettings)
Check if the contents of this object is the same as another object
Protected methodFinalize
Passively reclaims unmanaged resources when the class user did not explicitly call Dispose().
(Overrides ObjectFinalize.)
Public methodGetMargins
Get distances from the edge of the paper (MediaSize) to the CropRectangle in a defined unit system
Public methodGetModelScale
Returns the model scale factor.
Public methodGetOffset
Public methodGetViewport
Get RhinoViewport that this view capture settings is targeting
Public methodLoad
Public methodMatchViewportAspectRatio
Adjust crop rectangle to match the aspect ratio of the original viewport that these settings reference
Public methodMaximizePrintableArea
Minimize cropping so the full drawable area is used
Public methodSave
Public methodSetLayout
Public methodSetMarginBottom
Set the distance from the bottom edge of the paper to the CropRectangle
Public methodSetMarginLeft
Set the distance from the left edge of the paper to the CropRectangle
Public methodSetMarginRight
Set the distance from the right edge of the paper to the CropRectangle
Public methodSetMargins
Set distances from the edge of the paper (MediaSize) to the CropRectange in a defined unit system
Public methodSetMarginTop
Set the distance from the top edge of the paper to the CropRectangle
Public methodSetModelScaleToFit
Scales the model to fit.
Public methodSetModelScaleToValue
Sets the model scale to a value.
Public methodSetOffset
Public methodSetViewport
Public methodSetWindowRect(Point2d, Point2d)
Set the print area to a window selection based on two points in screen coordinates
Public methodSetWindowRect(Point3d, Point3d)
Set the print area to a window selection based on two points in world coordinates
Top
See Also