Click or drag to resize

ViewCaptureSettings Properties

The ViewCaptureSettings type exposes the following members.

Properties
  NameDescription
Public propertyApplyDisplayModeThicknessScales
Should curves and edges have their thicknesses scaled based the on the display mode settings for a view being captured (default is false)
Public propertyArrowheadSizeMillimeters
Arrowhead size in millimeters.
Public propertyCropRectangle
Actual area of output rectangle that view capture is sent to.
Public propertyDefaultPrintWidthMillimeters
Line thickness, in millimeters, used to print objects with no defined thickness.
Public propertyDocument
Public propertyDrawAxis
Public propertyDrawBackground
Public propertyDrawBackgroundBitmap
Public propertyDrawClippingPlanes
Public propertyDrawGrid
Public propertyDrawLights
Public propertyDrawLockedObjects
Public propertyDrawMargins
Public propertyDrawRectangle
Rectangle where drawing is confined to on MediaSize
Public propertyDrawSelectedObjectsOnly
Public propertyDrawWallpaper
Public propertyFooterText
Text drawn at the bottom of the output
Public propertyHeaderText
Text drawn at the top of the output
Public propertyHorizontalScale
Horizontal stretch to be applied to output. Useful for calibrating printers
Public propertyIsScaleToFit
Returns true if the model has been scaled to fit.
Public propertyIsValid
Public propertyLinetypeWidthUnitsArePageLengths
Public propertyMatchLinetypePatternDefinition
Default is true. Linetype scales are normally generated right before printing/view capture in order to get linetypes to print to the same lengths as defined. If false, the linetypes are not scaled and the current pattern lengths as seen on the screen as used.
Public propertyMediaSize
Total size of the image or page in dots
Public propertyModelScaleType
Public propertyOffsetAnchor
Public propertyOutputColor
Public propertyPointSizeMillimeters
Size of point objects in millimeters. if scale <= 0 the size is minimized so points are always drawn as small as possible
Public propertyRasterMode
Public propertyResolution
Capture "density" in dots per inch.
Public propertyTextDotPointSize
Font point size use for printing text dots. The default value is 10.0.
Public propertyUsePrintWidths
Public propertyVerticalScale
Vertical stretch to be applied to output. Useful for calibrating printers
Public propertyViewArea
How the RhinoViewport is mapped to the output rectangle
Public propertyWireThicknessScale
Scaling factor to apply to object print widths (typically 1.0). This is helpful when printing something at 1/2 scale and having all of the curves print 1/2 as thick.
Top
See Also