Click or drag to resize

ViewCaptureSettings Methods

The ViewCaptureSettings type exposes the following members.

Methods
  NameDescription
Public methodCreatePreviewSettings
Create a ViewCaptureSettings based on this instance, but scaled to fit in a different sized area. Scaling is also performed on dpi. This is primarily used to for capturing images that are shown as print previews
Public methodDispose
Actively reclaims unmanaged resources that this instance uses.
Public methodEquals(ViewCaptureSettings)
Check if the contents of this object is the same as another object
Protected methodFinalize
Passively reclaims unmanaged resources when the class user did not explicitly call Dispose().
(Overrides ObjectFinalize.)
Public methodGetMargins
Get distances from the edge of the paper (MediaSize) to the CropRectangle in a defined unit system
Public methodGetModelScale
Returns the model scale factor.
Public methodGetOffset
Public methodGetViewport
Get RhinoViewport that this view capture settings is targeting
Public methodLoad
Public methodMatchViewportAspectRatio
Adjust crop rectangle to match the aspect ratio of the original viewport that these settings reference
Public methodMaximizePrintableArea
Minimize cropping so the full drawable area is used
Public methodSave
Public methodSetLayout
Public methodSetMarginBottom
Set the distance from the bottom edge of the paper to the CropRectangle
Public methodSetMarginLeft
Set the distance from the left edge of the paper to the CropRectangle
Public methodSetMarginRight
Set the distance from the right edge of the paper to the CropRectangle
Public methodSetMargins
Set distances from the edge of the paper (MediaSize) to the CropRectange in a defined unit system
Public methodSetMarginTop
Set the distance from the top edge of the paper to the CropRectangle
Public methodSetModelScaleToFit
Scales the model to fit.
Public methodSetModelScaleToValue
Sets the model scale to a value.
Public methodSetOffset
Public methodSetViewport
Public methodSetWindowRect(Point2d, Point2d)
Set the print area to a window selection based on two points in screen coordinates
Public methodSetWindowRect(Point3d, Point3d)
Set the print area to a window selection based on two points in world coordinates
Top
See Also