Click or drag to resize

DisplayMaterial Class

[Missing <summary> documentation for "T:Rhino.Display.DisplayMaterial"]

Inheritance Hierarchy
SystemObject
  Rhino.DisplayDisplayMaterial

Namespace:  Rhino.Display
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class DisplayMaterial : IDisposable

The DisplayMaterial type exposes the following members.

Constructors
  NameDescription
Public methodDisplayMaterial
Constructs a default material.
Public methodDisplayMaterial(Color)
Constructs a default material with a specific diffuse color.
Public methodDisplayMaterial(DisplayMaterial)
Duplicate another material.
Public methodDisplayMaterial(Material)
Initializes a new instance of the DisplayMaterial class
Public methodDisplayMaterial(Color, Double)
Constructs a default material with a specific diffuse color and transparency.
Public methodDisplayMaterial(Color, Color, Color, Color, Double, Double)
Constructs a material with custom properties.
Top
Properties
  NameDescription
Public propertyBackDiffuse
Gets or sets the Diffuse color of the back side of the Material. The alpha component of the color will be ignored.
Public propertyBackEmission
Gets or sets the Emissive color of the back side of the Material. The alpha component of the color will be ignored.
Public propertyBackShine
Gets or sets the shine factor of the back side of the material (0.0 to 1.0)
Public propertyBackSpecular
Gets or sets the Specular color of the back side of the Material. The alpha component of the color will be ignored.
Public propertyBackTransparency
Gets or sets the transparency of the back side material (0.0 = opaque to 1.0 = transparent)
Public propertyDiffuse
Gets or sets the Diffuse color of the Material. The alpha component of the color will be ignored.
Public propertyEmission
Gets or sets the Emissive color of the Material. The alpha component of the color will be ignored.
Public propertyIsTwoSided
Public propertyShine
Gets or sets the shine factor of the material (0.0 to 1.0)
Public propertySpecular
Gets or sets the Specular color of the Material. The alpha component of the color will be ignored.
Public propertyTransparency
Gets or sets the transparency of the material (0.0 = opaque to 1.0 = transparent)
Top
Methods
  NameDescription
Public methodDispose
Releases all resources used by the DisplayMaterial
Protected methodDispose(Boolean)
Releases the unmanaged resources used by the DisplayMaterial and optionally releases the managed resources
Protected methodFinalize (Overrides ObjectFinalize.)
Public methodGetBitmapTexture
Public methodGetBumpTexture
Gets the bump texture for this display material.
Public methodGetEnvironmentTexture
Public methodGetTransparencyTexture
Public methodSetBitmapTexture(String, Boolean)
Public methodSetBitmapTexture(Texture, Boolean)
Public methodSetBumpTexture(String, Boolean)
Public methodSetBumpTexture(Texture, Boolean)
Public methodSetEnvironmentTexture(String, Boolean)
Public methodSetEnvironmentTexture(Texture, Boolean)
Public methodSetTransparencyTexture(String, Boolean)
Public methodSetTransparencyTexture(Texture, Boolean)
Top
See Also