Click or drag to resize

ColorXYZ Structure

Represents an XYZ (Hue, Saturation, Luminance) color with double precision floating point channels. XYZ colors are based on the CIE 1931 XYZ color space standard and they mimic the natural sensitivity of cones in the human retina.

Namespace:  Rhino.Display
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
[SerializableAttribute]
public struct ColorXYZ

The ColorXYZ type exposes the following members.

Constructors
  NameDescription
Public methodColorXYZ(Color)
Constructs a new instance of ColorXYZ that is equivalent to an ARGB color.
Public methodColorXYZ(Double, Double, Double)
Constructs a new instance of ColorXYZ with custom channel values.
Public methodColorXYZ(Double, Double, Double, Double)
Constructs a new instance of ColorXYZ with custom channel values.
Top
Properties
  NameDescription
Public propertyA
Gets or set the Alpha channel value. Channel will be limited to 0~1.
Public propertyX
Gets or set the X channel value. Channel will be limited to 0~1.
Public propertyY
Gets or set the Y channel value. Channel will be limited to 0~1.
Public propertyZ
Gets or set the Z channel value. Channel will be limited to 0~1.
Top
Methods
  NameDescription
Public methodStatic memberCreateFromCMYK
Create the nearest XYZ equivalent of a CMYK color.
Public methodStatic memberCreateFromHSL
Create the nearest XYZ equivalent of an HSL color.
Public methodStatic memberCreateFromHSV
Constructs the nearest XYZ equivalent of an HSV color.
Public methodStatic memberCreateFromLAB
Create the nearest XYZ equivalent of a Lab color.
Public methodStatic memberCreateFromLCH
Create the nearest XYZ equivalent of an LCH color.
Public methodStatic memberCreateFromRGBA
Create the nearest XYZ equivalent of a RGBA color.
Top
Operators
See Also