Click or drag to resize

ColorCMYK Structure

Represents a CMYK (Cyan, Magenta, Yellow, Key) color with double precision floating point channels. CMYK colors are used primarily in printing environments as they provide a good simulation of physical ink.

Namespace:  Rhino.Display
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
[SerializableAttribute]
public struct ColorCMYK

The ColorCMYK type exposes the following members.

Constructors
  NameDescription
Public methodColorCMYK(Color)
Initializes a new instance of ColorCMYK that is equivalent to an ARGB color.
Public methodColorCMYK(Double, Double, Double)
Initializes a new instance of ColorCMYK with custom channel values. The cyan, magenta and yellow values will be adjusted based on their combined darkness.
Public methodColorCMYK(Double, Double, Double, Double)
Initializes a new instance of ColorCMYK with custom channel values.
Public methodColorCMYK(Double, Double, Double, Double, Double)
Initializes a new instance of ColorCMYK with custom channel values.
Top
Properties
  NameDescription
Public propertyA
Gets or sets the Alpha channel value. Alpha channels are limited to the 0~1 range.
Public propertyC
Gets or sets the Cyan channel value. Cyan channels are limited to the 0~1 range.
Public propertyK
Gets or sets the Key channel value. Key channels are limited to the 0~1 range.
Public propertyM
Gets or sets the Magenta channel value. Magenta channels are limited to the 0~1 range.
Public propertyY
Gets or sets the Yellow channel value. Yellow channels are limited to the 0~1 range.
Top
Methods
  NameDescription
Public methodStatic memberCreateFromHSL
Constructs the nearest CMYK equivalent of an HSL color.
Public methodStatic memberCreateFromHSV
Constructs the nearest CMYK equivalent of an HSV color.
Public methodStatic memberCreateFromLAB
Constructs the nearest CMYK equivalent of a LAB color.
Public methodStatic memberCreateFromLCH
Constructs the nearest CMYK equivalent of a LCH color.
Public methodStatic memberCreateFromRGBA
Create the nearest CMYK equivalent of a RGBA color.
Public methodStatic memberCreateFromXYZ
Constructs the nearest CMYK equivalent of an XYZ color.
Top
Operators
See Also