Click or drag to resize

Panels Methods

The Panels type exposes the following members.

Methods
  NameDescription
Public methodStatic memberChangePanelIcon(Type, Icon)
Update the icon used for a panel tab.
Public methodStatic memberChangePanelIcon(Type, String)
Update the icon used for a panel tab.
Public methodStatic memberClosePanel(Guid)
Will close or hide the specified panel type, in Windows Rhino, if it is the only visible tab the tab dock bar will be closed as well. In Mac Rhino it will always close the modeless dialog hosting the panel.
Public methodStatic memberClosePanel(Type)
Will close or hide the specified panel type, in Windows Rhino, if it is the only visible tab the tab dock bar will be closed as well. In Mac Rhino it will always close the modeless dialog hosting the panel.
Public methodStatic memberClosePanel(Guid, RhinoDoc)
Will close or hide the specified panel type, in Windows Rhino, if it is the only visible tab the tab dock bar will be closed as well. In Mac Rhino it will always close the modeless dialog hosting the panel.
Public methodStatic memberClosePanel(Type, RhinoDoc)
Will close or hide the specified panel type, in Windows Rhino, if it is the only visible tab the tab dock bar will be closed as well. In Mac Rhino it will always close the modeless dialog hosting the panel.
Public methodStatic memberDockBarIdInUse
For internal use, call this method to see if a dock bar Id is currently being used by any Rhino dock bar. Rhino
Public methodStatic memberFloatPanel(Guid, PanelsFloatPanelMode)
Mac support: Display the specified panel in a floating window on Mac, the floating window will only contain the specified panel. Windows support: On Windows this will show or hide the floating container containing the specified panel. If the tab is docked with other tabs it will be floated in a new container.
Public methodStatic memberFloatPanel(Type, PanelsFloatPanelMode)
Mac support: Display the specified panel in a floating window on Mac, the floating window will only contain the specified panel. Windows support: On Windows this will show or hide the floating container containing the specified panel. If the tab is docked with other tabs it will be floated in a new container.
Public methodStatic memberGetOpenPanelIds
Get a list of the currently open panel tabs in Windows Rhino, on Mac Rhino it will be a list of the currently visible modeless panel dialogs.
Public methodStatic memberGetPanel(Guid) Obsolete.
Will return an instance of a .Net panel if the panel has been displayed at least once. Panel instances are not created until a panel is displayed.
Public methodStatic memberGetPanel(Guid, RhinoDoc)
Will return an instance of a .Net panel if the panel has been displayed at least once. Panel instances are not created until a panel is displayed.
Public methodStatic memberGetPanel(Guid, UInt32)
Will return an instance of a .Net panel if the panel has been displayed at least once. Panel instances are not created until a panel is displayed.
Public methodStatic memberGetPanelT Obsolete.
Return an instance of a .Net panel
Public methodStatic memberGetPanelT(RhinoDoc)
Return an instance of a .Net panel
Public methodStatic memberGetPanelT(UInt32)
Return an instance of a .Net panel
Public methodStatic memberGetPanels(Guid, RhinoDoc)
Gets the panels.
Public methodStatic memberGetPanels(Guid, UInt32)
Gets the panels.
Public methodStatic memberGetPanelsT(RhinoDoc)
Public methodStatic memberGetPanelsT(UInt32)
Gets the panels.
Public methodStatic memberIsHiding
Check to see if reason is equal to any of the show events
Public methodStatic memberIsPanelVisible(Guid)
Check to see if a panel is currently visible, on Windows this means you can see the tab, it does not necessarily mean it is the current tab.
Public methodStatic memberIsPanelVisible(Type)
Check to see if a panel is currently visible, on Windows this means you can see the tab, it does not necessarily mean it is the current tab.
Public methodStatic memberIsPanelVisible(Guid, Boolean)
Check to see if a panel is currently visible, if isSelectedTab is true then the tab must be the active tab as well.
Public methodStatic memberIsPanelVisible(Type, Boolean)
Check to see if a panel is currently visible, if isSelectedTab is true then the tab must be the active tab as well.
Public methodStatic memberIsShowing
Check to see if reason is equal to any of the hide events
Public methodStatic memberOnClosePanel
Call this method to raise the Closed event
Public methodStatic memberOnShowPanel
Call this method to raise the Show event
Public methodStatic memberOpenPanel(Guid)
Open the specified panel in its current or default location and if it is in a dock bar containing more than one tab, make it the current tab.
Public methodStatic memberOpenPanel(Type)
Open the specified panel in its current or default location and if it is in a dock bar containing more than one tab, make it the current tab.
Public methodStatic memberOpenPanel(Guid, Boolean)
Open the specified panel in its current or default location and if it is in a dock bar containing more than one tab, make it the current tab.
Public methodStatic memberOpenPanel(Guid, Guid)
In Mac Rhino this will just call the version of OpenPanel that takes a class type Id. In Windows Rhino this will look for a dock bar with the specified Id and open or move the specified panel to that dock bar.
Public methodStatic memberOpenPanel(Guid, Type)
In Mac Rhino this will just call the version of OpenPanel that takes a class type Id. In Windows Rhino this will look for a dock bar with the specified Id and open or move the specified panel to that dock bar.
Public methodStatic memberOpenPanel(Type, Boolean)
Open the specified panel in its current or default location and if it is in a dock bar containing more than one tab, make it the current tab.
Public methodStatic memberOpenPanel(Guid, Guid, Boolean)
In Mac Rhino this will just call the version of OpenPanel that takes a class type Id. In Windows Rhino this will look for a dock bar with the specified Id and open or move the specified panel to that dock bar.
Public methodStatic memberOpenPanel(Guid, Type, Boolean)
In Mac Rhino this will just call the version of OpenPanel that takes a class type Id. In Windows Rhino this will look for a dock bar with the specified Id and open or move the specified panel to that dock bar.
Public methodStatic memberOpenPanelAsSibling(Guid, Guid)
In Mac Rhino this will currently just call OpenPanel, in Windows Rhino this will look for a dock bar which contains the sibling panel and add this panel to that dock bar as necessary, if the panel was in another dock bar it will be moved to this dock bar.
Public methodStatic memberOpenPanelAsSibling(Guid, Guid, Boolean)
In Mac Rhino this will currently just call OpenPanel, in Windows Rhino this will look for a dock bar which contains the sibling panel and add this panel to that dock bar as necessary, if the panel was in another dock bar it will be moved to this dock bar.
Public methodStatic memberPanelDockBar(Guid)
Will always return Guid.Empty in Mac Rhino. In Windows Rhino it will look for the dock bar which contains the specified panel class Id and return the dock bar Id.
Public methodStatic memberPanelDockBar(Type)
Will always return Guid.Empty in Mac Rhino. In Windows Rhino it will look for the dock bar which contains the specified panel class Id and return the dock bar Id.
Public methodStatic memberPanelDockBars
Will always return a empty array in Mac Rhino. In Windows Rhino it will look for any panel dock bars that contain the specified panel class Id and return the dock bar Id's.
Public methodStatic memberRegisterPanel(PlugIn, Type, String, Icon)
You typically register your panel class in your plug-in's OnLoad function. This will register your custom call with Rhino, Rhino will create an instance of your class the first time your panel is created and embed this instance of your class in a panel container.
Public methodStatic memberRegisterPanel(PlugIn, Type, String, Icon, PanelType)
Call once to register a panel type which will get dynamically created and embedded in a Rhino docking/floating location.
Public methodStatic memberRegisterPanel(PlugIn, Type, String, Assembly, String, PanelType)
You typically register your panel class in your plug-in's OnLoad function. This will register your custom call with Rhino, Rhino will create an instance of your class the first time your panel is created and embed this instance of your class in a panel container.
Top
See Also