Click or drag to resize

VolumeMassProperties Methods

The VolumeMassProperties type exposes the following members.

Methods
  NameDescription
Public methodCentroidCoordinatesPrincipalMoments
Calculates the eigenvalues and eigenvectors of the moments matrix with respect to centroid coordinates.
Public methodCentroidCoordinatesPrincipalMomentsOfInertia
Calculates the principal moments of inertia and principal axes with respect to centroid coordinates.
Public methodStatic memberCompute(Brep)
Compute the VolumeMassProperties for a single Brep.
Public methodStatic memberCompute(IEnumerableGeometryBase)
Computes the VolumeMassProperties for a collection of geometric objects. At present only Breps, Surfaces, and Meshes are supported.
Public methodStatic memberCompute(Mesh)
Compute the VolumeMassProperties for a single Mesh.
Public methodStatic memberCompute(Surface)
Compute the VolumeMassProperties for a single Surface.
Public methodStatic memberCompute(Brep, Boolean, Boolean, Boolean, Boolean)
Compute the VolumeMassProperties for a single Brep.
Public methodStatic memberCompute(IEnumerableGeometryBase, Boolean, Boolean, Boolean, Boolean)
Computes the VolumeMassProperties for a collection of geometric objects. At present only Breps, Surfaces, Meshes and Planar Closed Curves are supported.
Public methodStatic memberCompute(Mesh, Boolean, Boolean, Boolean, Boolean)
Compute the VolumeMassProperties for a single Mesh.
Public methodStatic memberCompute(Surface, Boolean, Boolean, Boolean, Boolean)
Compute the VolumeMassProperties for a single Surface.
Public methodStatic memberCompute(Brep, Boolean, Boolean, Boolean, Boolean, Double, Double)
Compute the VolumeMassProperties for a single Brep.
Public methodDispose
Actively reclaims unmanaged resources that this instance uses.
Protected methodDispose(Boolean)
For derived class implementers.

This method is called with argument true when class user calls Dispose(), while with argument false when the Garbage Collector invokes the finalizer, or Finalize() method.

You must reclaim all used unmanaged resources in both cases, and can use this chance to call Dispose on disposable fields if the argument is true.

Also, you must call the base virtual method within your overriding method.

Protected methodFinalize
Passively reclaims unmanaged resources when the class user did not explicitly call Dispose().
(Overrides ObjectFinalize.)
Public methodSum
Sum mass properties together to get an aggregate mass.
Public methodWorldCoordinatesPrincipalMoments
Calculates the eigenvalues and eigenvectors of moments matrix in world coordinates.
Public methodWorldCoordinatesPrincipalMomentsOfInertia
Calculates the principal moments of inertia and principal axes with respect to world coordinates.
Top
See Also