Click or drag to resize

VolumeMassPropertiesCompute Method (IEnumerableGeometryBase)

Computes the VolumeMassProperties for a collection of geometric objects. At present only Breps, Surfaces, and Meshes are supported.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 6.3
Syntax
public static VolumeMassProperties Compute(
	IEnumerable<GeometryBase> geometry
)

Parameters

geometry
Type: System.Collections.GenericIEnumerableGeometryBase
Objects to include in the volume computation.

Return Value

Type: VolumeMassProperties
The VolumeMassProperties for the entire collection or null on failure.
See Also