Click or drag to resize

VolumeMassPropertiesCompute Method (Surface)

Compute the VolumeMassProperties for a single Surface.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public static VolumeMassProperties Compute(
	Surface surface
)

Parameters

surface
Type: Rhino.GeometrySurface
Surface to measure.

Return Value

Type: VolumeMassProperties
The VolumeMassProperties for the given Surface or null on failure.
Exceptions
ExceptionCondition
ArgumentNullExceptionWhen surface is null.
See Also