Click or drag to resize

MeshFace Methods

The MeshFace type exposes the following members.

Methods
  NameDescription
Public methodCompareTo
Compares this MeshFace with another MeshFace and returns a value of 1, 0, or -1, referring to dictionary order.

Index evaluation priority is first A, then B, then C, then D.

Public methodEquals(MeshFace)
Returns a value indicating whether the other mesh face has precisely the same value as the current one.
Public methodEquals(Object)
Returns a value indicating whether the other object obj has precisely the same value as the current one.
(Overrides ValueTypeEquals(Object).)
Public methodFlip
Reverses the orientation of the face by swapping corners. The first corner is always maintained.
Public methodGetHashCode
Returns a runtime-stable hash code for the current mesh face. You are not allowed to rely on persistence of this hash code in serialization, but for each version of RhinoCommon, this hash code will be the same for each mesh face.
(Overrides ValueTypeGetHashCode.)
Public methodIsValid
Gets a value indicating whether or not this mesh face is considered to be valid. Note that even valid mesh faces could potentially be invalid in the context of a specific Mesh, if one or more of the corner indices exceeds the number of vertices on the mesh. If you want to perform a complete validity check, use IsValid(int) instead.
Public methodIsValid(Int32)
Gets a value indicating whether or not this mesh face is considered to be valid. Unlike the simple IsValid function, this function takes upper bound indices into account.
Public methodIsValid(Point3d)
Gets a value indicating whether or not this mesh face is considered to be valid. Unlike the simple IsValid function, this function takes actual point locations into account.
Public methodIsValidEx
Gets a value indicating whether or not this mesh face is considered to be valid. Unlike the simple IsValid function, this function takes actual point locations into account.
Public methodRepair
Attempts to repair this mesh face by taking both face indexes and actual vertex locations into account.
Public methodRepairEx
Attempts to repair this mesh face by taking both face indexes and actual vertex locations into account.
Public methodSet(Int32, Int32, Int32)
Sets all the corners for this face as a triangle.
Public methodSet(Int32, Int32, Int32, Int32)
Sets all the corners for this face as a quad.
Public methodToString
Returns a string representation for this MeshFace. This is to provide a meaningful visualization of this structure and is subject to change in newer releases.
(Overrides ValueTypeToString.)
Top
See Also