Click or drag to resize

Line Methods

The Line type exposes the following members.

Methods
  NameDescription
Public methodClosestParameter
Finds the parameter on the infinite line segment that is closest to a test point.
Public methodClosestPoint
Finds the point on the (in)finite line segment that is closest to a test point.
Public methodDistanceTo
Compute the shortest distance between this line segment and a test point.
Public methodEpsilonEquals
Check that all values in other are within epsilon of the values in this
Public methodEquals(Line)
Determines whether a line has the same value as this line.
Public methodEquals(Object)
Determines whether an object is a line that has the same value as this line.
(Overrides ValueTypeEquals(Object).)
Public methodExtend
Extend the line by custom distances on both sides.
Public methodExtendThroughBox(BoundingBox)
Ensure the line extends all the way through a box. Note, this does not result in the shortest possible line that overlaps the box.
Public methodExtendThroughBox(Box)
Ensure the line extends all the way through a box. Note, this does not result in the shortest possible line that overlaps the box.
Public methodExtendThroughBox(BoundingBox, Double)
Ensure the line extends all the way through a box. Note, this does not result in the shortest possible line that overlaps the box.
Public methodExtendThroughBox(Box, Double)
Ensure the line extends all the way through a box. Note, this does not result in the shortest possible line that overlaps the box.
Public methodFlip
Flip the endpoints of the line segment.
Public methodGetHashCode
Computes a hash number that represents this line.
(Overrides ValueTypeGetHashCode.)
Public methodMaximumDistanceTo(Line)
Finds the largest distance between this line as a finite segment and another finite segment.
Public methodMaximumDistanceTo(Point3d)
Finds the largest distance between this line as a finite segment and a test point.
Public methodMinimumDistanceTo(Line)
Finds the shortest distance between this line as a finite segment and another finite segment.
Public methodMinimumDistanceTo(Point3d)
Finds the shortest distance between this line as a finite segment and a test point.
Public methodCode examplePointAt
Evaluates the line at the specified parameter.
Public methodPointAtLength
Computes a point located at a specific metric distance from the line origin (From).

If line start and end coincide, then the start point is always returned.

Public methodToNurbsCurve
Constructs a nurbs curve representation of this line. This amounts to the same as calling NurbsCurve.CreateFromLine().
Public methodToString
Constructs the string representation of this line, in the form "From,To".
(Overrides ValueTypeToString.)
Public methodToString(String, IFormatProvider)
Formats the value of the current instance using the specified format.
Public methodTransform
Transform the line using a Transformation matrix.
Public methodStatic memberTryCreateBetweenCurves
Creates a line segment between a pair of curves such that the line segment is either tangent or perpendicular to each of the curves.
Public methodStatic memberTryFitLineToPoints
Attempt to fit a line through a set of points.
Public methodTryGetPlane
Gets a plane that contains the line. The origin of the plane is at the start of the line. If possible, a plane parallel to the world XY, YZ, or ZX plane is returned.
Top
See Also