Click or drag to resize

LineDistanceTo Method

Compute the shortest distance between this line segment and a test point.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public double DistanceTo(
	Point3d testPoint,
	bool limitToFiniteSegment
)

Parameters

testPoint
Type: Rhino.GeometryPoint3d
Point for distance computation.
limitToFiniteSegment
Type: SystemBoolean
If true, the distance is limited to the finite line segment.

Return Value

Type: Double
The shortest distance between this line segment and testPoint.
See Also