Extend the line by custom distances on both sides.
Namespace:
Rhino.Geometry
Assembly:
RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax public bool Extend(
double startLength,
double endLength
)
Public Function Extend (
startLength As Double,
endLength As Double
) As Boolean
Parameters
- startLength
- Type: SystemDouble
Distance to extend the line at the start point.
Positive distance result in longer lines.
- endLength
- Type: SystemDouble
Distance to extend the line at the end point.
Positive distance result in longer lines.
Return Value
Type:
Booleantrue on success, false on failure.
See Also