Click or drag to resize

DimensionStyle Methods

The DimensionStyle type exposes the following members.

Methods
  NameDescription
Public methodAlternateDimensionLengthDisplayUnit
Public methodClearAllFieldOverrides
Sets all the fields in this DimensionStyle to be not overridden Does not change any dimstyle_id's or parent_id's
Public methodClearFieldOverride
Set the field as not overridden
Public methodCopyFrom
Copy settings from source dimension style without changing the name, Id or index of this DimensionStyle.
Public methodCreatePreviewBitmap
Public methodDeleteAllUserStrings
Public methodDeleteUserString
Public methodDimensionLengthDisplayUnit
Protected methodDispose(Boolean)
For derived class implementers.

This method is called with argument true when class user calls Dispose(), while with argument false when the Garbage Collector invokes the finalizer, or Finalize() method.

You must reclaim all used unmanaged resources in both cases, and can use this chance to call Dispose on disposable fields if the argument is true.

Also, you must call the base virtual method within your overriding method.
Public methodDuplicate
Construct a deep (full) copy of this object.
Public methodDuplicate(String, Guid, Guid)
Construct a deep (full) copy of this object.
Public methodGetUserString
Gets user string from this geometry.
Public methodGetUserStrings
Gets a copy of all (user key string, user value string) pairs attached to this geometry.
Public methodIsChildOf
Tests if this DimensionStyle is a child of a specific DimensionStyle
Public methodIsFieldOverriden
Public methodScaleLengthValues
Scales all length values by 'scale'
Public methodSetFieldOverride
Set a field as overridden
Public methodSetUserString
Attach a user string (key,value combination) to this geometry.
Top
See Also