Click or drag to resize

Vector3dAreOrthonormal Method

Test whether three vectors describe an orthogonal, unit axis system. All vectors must be mutually perpendicular and have unit length for this to be the case.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 6.7
Syntax
public static bool AreOrthonormal(
	Vector3d x,
	Vector3d y,
	Vector3d z
)

Parameters

x
Type: Rhino.GeometryVector3d
X axis vector.
y
Type: Rhino.GeometryVector3d
Y axis vector.
z
Type: Rhino.GeometryVector3d
Z axis vector.

Return Value

Type: Boolean
True if all vectors are non-zero and mutually perpendicular.
See Also