Click or drag to resize

IStackedDialogPageService Interface

For internal use, the IStackedDialogPageService service is implemented in RhinoWindows or RhinoMac as appropriate and handles the communication with core Rhino

Namespace:  Rhino.UI
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public interface IStackedDialogPageService

The IStackedDialogPageService type exposes the following members.

Methods
  NameDescription
Public methodGetImageHandle(Icon, Boolean)
Convert image to platform specific unmanaged pointer
Public methodGetImageHandle(Image, Boolean)
Convert image to platform specific unmanaged pointer
Public methodGetNativePageWindow(Object, Boolean, Boolean, Object)
Get the unmanaged pointer associated with the pages content control
Public methodGetNativePageWindow(Object, Boolean, Boolean, Object, Object)
Get the unmanaged pointer associated with the pages content control
Public methodNativeHandle
Gets the native window handle associated with the host object if there is one.
Public methodRedrawPageControl
Redraw the specified control.
Public methodSetNativeParent
Sets the parent on a host returned from GetNativePageWindow
Public methodTryGetControlMinimumSize
Get the minimum size associated with a control object
Top
See Also