Click or drag to resize

IStackedDialogPageServiceGetNativePageWindow Method (Object, Boolean, Boolean, Object, Object)

Get the unmanaged pointer associated with the pages content control

Namespace:  Rhino.UI
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 6.1
Syntax
IntPtr GetNativePageWindow(
	Object pageObject,
	bool isRhinoPanel,
	bool applyPanelStyles,
	out Object nativeWindowObject,
	out Object host
)

Parameters

pageObject
Type: SystemObject

[Missing <param name="pageObject"/> documentation for "M:Rhino.UI.IStackedDialogPageService.GetNativePageWindow(System.Object,System.Boolean,System.Boolean,System.Object@,System.Object@)"]

isRhinoPanel
Type: SystemBoolean

[Missing <param name="isRhinoPanel"/> documentation for "M:Rhino.UI.IStackedDialogPageService.GetNativePageWindow(System.Object,System.Boolean,System.Boolean,System.Object@,System.Object@)"]

applyPanelStyles
Type: SystemBoolean

[Missing <param name="applyPanelStyles"/> documentation for "M:Rhino.UI.IStackedDialogPageService.GetNativePageWindow(System.Object,System.Boolean,System.Boolean,System.Object@,System.Object@)"]

nativeWindowObject
Type: SystemObject

[Missing <param name="nativeWindowObject"/> documentation for "M:Rhino.UI.IStackedDialogPageService.GetNativePageWindow(System.Object,System.Boolean,System.Boolean,System.Object@,System.Object@)"]

host
Type: SystemObject

[Missing <param name="host"/> documentation for "M:Rhino.UI.IStackedDialogPageService.GetNativePageWindow(System.Object,System.Boolean,System.Boolean,System.Object@,System.Object@)"]

Return Value

Type: IntPtr

[Missing <returns> documentation for "M:Rhino.UI.IStackedDialogPageService.GetNativePageWindow(System.Object,System.Boolean,System.Boolean,System.Object@,System.Object@)"]

See Also