Click or drag to resize

DrawingUtilities Class

RhinoCommon Drawing Utilities
Inheritance Hierarchy
SystemObject
  Rhino.UIDrawingUtilities

Namespace:  Rhino.UI
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public static class DrawingUtilities

The DrawingUtilities type exposes the following members.

Methods
  NameDescription
Public methodStatic memberBitmapFromIconResource(String, Assembly)
Load a Icon from an embedded resource and convert it to a bitmap of the specified size. Will look for a icon image that is greater than or equal to the requested size, if all images are less than the requested size the largest image will be used.
Public methodStatic memberBitmapFromIconResource(String, Size, Assembly)
Load a Icon from an embedded resource and convert it to a bitmap of the specified size. Will look for a icon image that is greater than or equal to the requested size, if all images are less than the requested size the largest image will be used.
Public methodStatic memberBitmapFromSvg(String, Int32, Int32)
Create bitmap of a given size from an svg string
Public methodStatic memberBitmapFromSvg(String, Int32, Int32, Boolean)
Create bitmap of a given size from an svg string
Public methodStatic memberCreateCurvePreviewGeometry
Create a series of closed polyline loops representing a curve and a linetype combination.
Public methodStatic memberCreateMeshPreviewImage(IEnumerableMesh, IEnumerableColor, Size)
Creates a preview image of one or more meshes.
Public methodStatic memberCreateMeshPreviewImage(Mesh, Color, Size)
Creates a preview image of a mesh.
Public methodStatic memberCreateMeshPreviewImage(RhinoDoc, IEnumerableMesh, IEnumerableColor, Size)
Creates a preview image of one or more meshes.
Public methodStatic memberDarkModeConvertPixel
Public methodStatic memberDarkModeConvertPixels
Attempt to adjust pixels to an image that works for dark mode
Public methodStatic memberIconFromResource(String, Assembly)
Load a Icon from an embedded resource.
Public methodStatic memberIconFromResource(String, Size, Assembly)
Load a Icon from an embedded resource.
Public methodStatic memberImageFromResource
Load a Image from an embedded resource.
Public methodStatic memberLoadBitmapWithScaleDown
Loads an icon from an embedded resource and converts it to a bitmap. If the icon is not a standard size, this function scales down a larger image.
Public methodStatic memberLoadIconWithScaleDown
Loads an icon from an embedded resource. If the icon is not a standard size, this function scales down a larger image.
Public methodStatic memberMakeArgb
Public methodStatic memberPixelsFromSvg
Get array of bytes that represent RGBA values for an image of a given size created from SVG
Public methodStatic memberSvgToRhinoDibIntPtr
Create bitmap of a given size from an svg string
Top
See Also