Click or drag to resize

DrawingUtilitiesIconFromResource Method (String, Assembly)

Load a Icon from an embedded resource.

Namespace:  Rhino.UI
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 6.0
Syntax
public static Icon IconFromResource(
	string resourceName,
	Assembly assembly = null
)

Parameters

resourceName
Type: SystemString
The case-sensitive name of the icon manifest resource being requested.
assembly (Optional)
Type: System.ReflectionAssembly
The assembly containing the manifest resource, will use the calling assembly if null.

Return Value

Type: Icon
The Icon resource if found and loaded otherwise null.
See Also