Click or drag to resize

DrawingUtilities.PixelsFromSvg Method

Get array of bytes that represent RGBA values for an image of a given size created from SVG

Namespace:  Rhino.UI
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 8.0
Syntax
public static byte[] PixelsFromSvg(
	string svg,
	int width,
	int height,
	bool premultiplyAlpha,
	Color backgroundColor
)

Parameters

svg
Type: System.String

[Missing <param name="svg"/> documentation for "M:Rhino.UI.DrawingUtilities.PixelsFromSvg(System.String,System.Int32,System.Int32,System.Boolean,System.Drawing.Color)"]

width
Type: System.Int32

[Missing <param name="width"/> documentation for "M:Rhino.UI.DrawingUtilities.PixelsFromSvg(System.String,System.Int32,System.Int32,System.Boolean,System.Drawing.Color)"]

height
Type: System.Int32

[Missing <param name="height"/> documentation for "M:Rhino.UI.DrawingUtilities.PixelsFromSvg(System.String,System.Int32,System.Int32,System.Boolean,System.Drawing.Color)"]

premultiplyAlpha
Type: System.Boolean
Pre-lends the background color with the pixels based on their alpha value
backgroundColor
Type: System.Drawing.Color
Background color - pass Color.Empty if you don't know what to pass.

Return Value

Type:Byte[]

[Missing <returns> documentation for "M:Rhino.UI.DrawingUtilities.PixelsFromSvg(System.String,System.Int32,System.Int32,System.Boolean,System.Drawing.Color)"]

See Also