Click or drag to resize

DrawingUtilitiesBitmapFromSvg Method (String, Int32, Int32, Boolean)

Create bitmap of a given size from an svg string

Namespace:  Rhino.UI
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 8.0
Syntax
public static Bitmap BitmapFromSvg(
	string svg,
	int width,
	int height,
	bool adjustForDarkMode
)

Parameters

svg
Type: SystemString

[Missing <param name="svg"/> documentation for "M:Rhino.UI.DrawingUtilities.BitmapFromSvg(System.String,System.Int32,System.Int32,System.Boolean)"]

width
Type: SystemInt32

[Missing <param name="width"/> documentation for "M:Rhino.UI.DrawingUtilities.BitmapFromSvg(System.String,System.Int32,System.Int32,System.Boolean)"]

height
Type: SystemInt32

[Missing <param name="height"/> documentation for "M:Rhino.UI.DrawingUtilities.BitmapFromSvg(System.String,System.Int32,System.Int32,System.Boolean)"]

adjustForDarkMode
Type: SystemBoolean

[Missing <param name="adjustForDarkMode"/> documentation for "M:Rhino.UI.DrawingUtilities.BitmapFromSvg(System.String,System.Int32,System.Int32,System.Boolean)"]

Return Value

Type: Bitmap

[Missing <returns> documentation for "M:Rhino.UI.DrawingUtilities.BitmapFromSvg(System.String,System.Int32,System.Int32,System.Boolean)"]

See Also