ComponentFunctionInfo Class |
Namespace: Rhino.NodeInCode
The ComponentFunctionInfo type exposes the following members.
Name | Description | |
---|---|---|
![]() | ComponentFunctionInfo |
Instantiates a new instance of the function class. This is not meant for public consumption.
|
Name | Description | |
---|---|---|
![]() | ComponentGuid |
The unique identifier of the Grasshopper component.
It is the original developer's responsibility to ensure that this ID is unique.
|
![]() | Delegate |
Returns a delegate that can be directly invoked using a list of arguments.
This flattens trees.
|
![]() | DelegateNoWarnings |
Returns a delegate that can be directly invoked using a list of arguments.
This flattens trees.
|
![]() | DelegateTree |
Returns a delegate that can be directly invoked using a list of arguments.
This considers trees and simplifies single-output components.
|
![]() | DelegateTreeNoWarnings |
Returns a delegate that can be directly invoked using a list of arguments.
This considers trees and simplifies single-output components.
|
![]() | Description |
The function description.
|
![]() | FullName |
Returns the name of the component prefixed by, if existing, the namespace.
|
![]() | FullScriptingName |
Shows the full name of the component, including optional periods.
Removes spaces and common operator signs.
|
![]() | InputDescriptions |
The function input parameter descriptions.
|
![]() | InputNames |
The function input parameter names.
|
![]() | InputsOptional |
Indications for each function input parameter whether it is optional.
|
![]() | InputTypeNames |
The function input type names.
|
![]() | IsDefault |
Determines if the component is a default one.
|
![]() | Name |
The function name.
|
![]() | Namespace |
The function namespace.
|
![]() | OutputDescriptions |
Grasshopper returns several items in general. This property returns the output descriptions.
|
![]() | OutputNames |
Grasshopper returns several items in general. This property returns the output names.
|
![]() | OutputTypeNames |
Grasshopper returns several items in general. This property returns the output type names.
|
Name | Description | |
---|---|---|
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.) |
![]() | Evaluate |
Evaluates the component with a set of arguments.
There needs to be an argument for each input param, and each output param gives an entry in the output array.
|
![]() | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object.) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object.) |
![]() | Invoke |
Runs Evaluate(IEnumerable, Boolean, String) with keepTree equal to false,
and raises an exception on the first warning.
|
![]() | InvokeKeepTree |
Runs Evaluate(IEnumerable, Boolean, String) with keepTree equal to true and raises an exception on the first warning.
|
![]() | InvokeKeepTreeSilenceWarnings |
Runs Evaluate(IEnumerable, Boolean, String) with keepTree equal to true,
and discards warnings (this is a dangerous operation!).
|
![]() | InvokeSilenceWarnings |
Runs Evaluate(IEnumerable, Boolean, String) with keepTree equal to false,
then simplifies output with SimplifyTreeOutput(Object, String, Boolean) and discards warnings (this is a dangerous operation!).
|
![]() | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.) |
![]() | ToString |
Returns a string representing this function.
(Overrides ObjectToString.) |