Click or drag to resize

ComponentFunctionInfo Properties

The ComponentFunctionInfo type exposes the following members.

Properties
  NameDescription
Public propertyComponentGuid
The unique identifier of the Grasshopper component. It is the original developer's responsibility to ensure that this ID is unique.
Public propertyDelegate
Returns a delegate that can be directly invoked using a list of arguments. This flattens trees.
Public propertyDelegateNoWarnings
Returns a delegate that can be directly invoked using a list of arguments. This flattens trees.
Public propertyDelegateTree
Returns a delegate that can be directly invoked using a list of arguments. This considers trees and simplifies single-output components.
Public propertyDelegateTreeNoWarnings
Returns a delegate that can be directly invoked using a list of arguments. This considers trees and simplifies single-output components.
Public propertyDescription
The function description.
Public propertyFullName
Returns the name of the component prefixed by, if existing, the namespace.
Public propertyFullScriptingName
Shows the full name of the component, including optional periods. Removes spaces and common operator signs.
Public propertyInputDescriptions
The function input parameter descriptions.
Public propertyInputNames
The function input parameter names.
Public propertyInputsOptional
Indications for each function input parameter whether it is optional.
Public propertyInputTypeNames
The function input type names.
Public propertyIsDefault
Determines if the component is a default one.
Public propertyName
The function name.
Public propertyNamespace
The function namespace.
Public propertyOutputDescriptions
Grasshopper returns several items in general. This property returns the output descriptions.
Public propertyOutputNames
Grasshopper returns several items in general. This property returns the output names.
Public propertyOutputTypeNames
Grasshopper returns several items in general. This property returns the output type names.
Top
See Also