Click or drag to resize

MaterialTable Class

[Missing <summary> documentation for "T:Rhino.DocObjects.Tables.MaterialTable"]

Inheritance Hierarchy
SystemObject
  Rhino.FileIOCommonComponentTableMaterial
    Rhino.DocObjects.TablesRhinoDocCommonTableMaterial
      Rhino.DocObjects.TablesMaterialTable

Namespace:  Rhino.DocObjects.Tables
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public sealed class MaterialTable : RhinoDocCommonTable<Material>, 
	ICollection<Material>, IEnumerable<Material>, IEnumerable

The MaterialTable type exposes the following members.

Properties
  NameDescription
Public propertyComponentType (Overrides CommonComponentTableTComponentType.)
Public propertyCurrentMaterialIndex
At all times, there is a "current" material. Unless otherwise specified, new objects are assigned to the current material. The current material is never locked, hidden, or deleted.
Public propertyCurrentMaterialSource
Gets or sets the current material source.
Public propertyItem
Conceptually, the material table is an array of materials. The operator[] can be used to get individual materials. A material is either active or deleted and this state is reported by Material.IsDeleted.
Top
Methods
  NameDescription
Public methodAdd
Adds a new material to the table based on the default material.
Public methodAdd(Material)
Adds a new material to the table based on a given material.
Public methodAdd(Material, Boolean)
Adds a new material to the table based on a given material.
Public methodDelete (Overrides CommonComponentTableTDelete(T).)
Public methodDeleteAt
Removes a material at a specific position from this material table.
Public methodFind(Guid, Boolean)
Finds a material with a matching id.
Public methodFind(Material, Boolean)
Finds a material index.
Public methodFind(String, Boolean)
Finds a material with a given name.
Public methodFindIndex
Retrieves a Material object based on Index. This search type of search is discouraged. We are moving towards using only IDs for all tables.
Public methodModify
Modify material settings.
Public methodResetMaterial
Top
See Also