MaterialTableAdd Method (Material, Boolean) |
Adds a new material to the table based on a given material.
Namespace:
Rhino.DocObjects.Tables
Assembly:
RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax public int Add(
Material material,
bool reference
)
Public Function Add (
material As Material,
reference As Boolean
) As Integer
Parameters
- material
- Type: Rhino.DocObjectsMaterial
A model of the material to be added. - reference
- Type: SystemBoolean
true if this material is supposed to be a reference material.
Reference materials are not saved in the file.
Return Value
Type:
Int32The position of the new material in the table.
See Also