Click or drag to resize

MaterialTable Methods

The MaterialTable type exposes the following members.

Methods
  NameDescription
Public methodAdd
Adds a new material to the table based on the default material.
Public methodAdd(Material)
Adds a new material to the table based on a given material.
Public methodAdd(Material, Boolean)
Adds a new material to the table based on a given material.
Public methodDelete (Overrides CommonComponentTableTDelete(T).)
Public methodDeleteAt
Removes a material at a specific position from this material table.
Public methodFind(Guid, Boolean)
Finds a material with a matching id.
Public methodFind(Material, Boolean)
Finds a material index.
Public methodFind(String, Boolean)
Finds a material with a given name.
Public methodFindIndex
Retrieves a Material object based on Index. This search type of search is discouraged. We are moving towards using only IDs for all tables.
Public methodModify
Modify material settings.
Public methodResetMaterial
Top
See Also