MaterialTable Properties |
The MaterialTable type exposes the following members.
Name | Description | |
---|---|---|
![]() | ComponentType | (Overrides CommonComponentTableTComponentType.) |
![]() | Count |
Returns the count of all items, including deleted ones.
(Inherited from CommonComponentTableT.) |
![]() | CurrentMaterialIndex |
At all times, there is a "current" material. Unless otherwise
specified, new objects are assigned to the current material.
The current material is never locked, hidden, or deleted.
|
![]() | CurrentMaterialSource |
Gets or sets the current material source.
|
![]() | Document | Document that owns this table. (Inherited from RhinoDocCommonTableT.) |
![]() | Item |
Conceptually, the material table is an array of materials.
The operator[] can be used to get individual materials. A material is
either active or deleted and this state is reported by Material.IsDeleted.
|