Click or drag to resize

ColorLCH Structure

Represents an LCH (Lightness, A, B) color with double precision floating point channels. LCH colors (also sometimes called CIELUV) are transformation of the 1931 CIE XYZ color space, in order to approach perceptual uniformity. They are primarily used in computer graphics which deal with colored lights.

Namespace:  Rhino.Display
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
[SerializableAttribute]
public struct ColorLCH

The ColorLCH type exposes the following members.

Constructors
  NameDescription
Public methodColorLCH(Color)
Constructs a new instance of ColorLCH that is equivalent to an ARGB color.
Public methodColorLCH(Double, Double, Double)
Constructs a new instance of ColorLCH with custom channel values.
Public methodColorLCH(Double, Double, Double, Double)
Constructs a new instance of ColorLCH with custom channel values.
Top
Properties
  NameDescription
Public propertyA
Gets or sets the Alpha channel. The Alpha channel is limited to the 0~1 range.
Public propertyC
Gets or sets the Chroma channel. Chroma is defined from -1.0 to +1.0.
Public propertyH
Gets or sets the Hue channel. The hue channel is limited to the 0~360 degree range.
Public propertyL
Gets or sets the Lightness channel.
Top
Methods
  NameDescription
Public methodStatic memberCreateFromCMYK
Create the nearest LCH equivalent of a CMYK color.
Public methodStatic memberCreateFromHSL
Create the nearest LCH equivalent of an HSL color.
Public methodStatic memberCreateFromLAB
Create the nearest LCH equivalent of a LAB color.
Public methodStatic memberCreateFromRGBA
Create the nearest LCH equivalent of an RGBA color.
Public methodStatic memberCreateFromXYZ
Create the nearest LCH equivalent of an XYZ color.
Public methodMakePositive
Ensure the Chromaticity of this color is positive.
Top
Operators
See Also