Click or drag to resize

ColorHSV Structure

Represents an HSV (Hue, Saturation, Value) color with double precision floating point channels. HSV colors (also sometimes called HSB, where B means Brightness) are similar to HSL colors in that they represent colors in a cylindrical color space, and are intended to provide intuitive means to edit the brightness of a particular color over RGB color space where each color channel would need to be modified to affect the color brightness.

Namespace:  Rhino.Display
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
[SerializableAttribute]
public struct ColorHSV

The ColorHSV type exposes the following members.

Constructors
  NameDescription
Public methodColorHSV(Color)
Constructs a new instance of ColorHSV that is equivalent to an ARGB color.
Public methodColorHSV(Double, Double, Double)
Constructs a new instance of ColorHSV with custom channel values.
Public methodColorHSV(Double, Double, Double, Double)
Constructs a new instance of ColorHSV with custom channel values.
Top
Properties
  NameDescription
Public propertyA
Gets or sets the alpha channel value. Alpha channels are limited to a 0~1 range.
Public propertyH
Gets or sets the hue channel value. Hue channels rotate between 0.0 and 1.0.
Public propertyS
Gets or sets the saturation channel value. Saturation channels are limited to a 0~1 range.
Public propertyV
Gets or sets the value (brightness) channel value. Value channels are limited to a 0~1 range.
Top
Methods
  NameDescription
Public methodStatic memberCreateFromCMYK
Create the nearest HSV equivalent of a CMYK color.
Public methodStatic memberCreateFromHSL
Constructs the nearest HSV equivalent of an HSL color.
Public methodStatic memberCreateFromLAB
Create the nearest HSV equivalent of a LAB color.
Public methodStatic memberCreateFromLCH
Create the nearest HSV equivalent of a LCH color.
Public methodStatic memberCreateFromRGBA
Create the nearest HSV equivalent of a RGBA color.
Public methodStatic memberCreateFromXYZ
Create the nearest HSV equivalent of an XYZ color.
Public methodToArgbColor
Convert HSV color to an equivalent System.Drawing.Color.
Top
Operators
See Also