Click or drag to resize

InstanceDefinitionGeometry Properties

The InstanceDefinitionGeometry type exposes the following members.

Properties
  NameDescription
Public propertyComponentType (Overrides ModelComponentComponentType.)
Public propertyDescription
Gets or sets the description of the definition.
Public propertyIsSystemComponent
True if this model component is a system constant.

An incomplete list of system constant model components is below:

  • ON_ModelComponent::Unset

  • ON_InstanceDefinition::Empty

  • ON_Linetype::Unset
  • ON_Linetype::Continuous
  • ON_Linetype::ByLayer
  • ON_Linetype::ByParent

  • ON_Layer::Unset
  • ON_Layer::Default

  • ON_TextStyle::Unset
  • ON_TextStyle::Default
  • ON_TextStyle::ByLayer
  • ON_TextStyle::ByParent

  • ON_DimStyle::Unset
  • ON_DimStyle::Default
  • ON_DimStyle::DefaultInchDecimal
  • ON_DimStyle::DefaultInchFractional
  • ON_DimStyle::DefaultFootInchArchitecture
  • ON_DimStyle::DefaultMillimeterSmall
  • ON_DimStyle::DefaultMillimeterLarge
Public propertySourceArchive
Gets the full file path for linked instance definitions.
Public propertyUrl
Gets or sets the URL or hyperlink of the definition.
Public propertyUrlDescription
Gets or sets the description of the URL or hyperlink of the definition.
Public propertyUserStringCount
Gets the amount of user strings.
Top
See Also