Click or drag to resize

Vector3f Operators and Type Conversions

The Vector3f type exposes the following members.

Operators
  NameDescription
Public operatorStatic memberAddition(Point3f, Vector3f)
Sums up a point and a vector, and returns a new point.
Public operatorStatic memberAddition(Vector3f, Vector3f)
Sums up two vectors.
Public operatorStatic memberDivision(Vector3f, Double)
Divides a Vector3f by a number, having the effect of shrinking it, t times.
Public operatorStatic memberDivision(Vector3f, Single)
Divides a Vector3f by a number, having the effect of shrinking it, t times.
Public operatorStatic memberEquality
Determines whether two vectors have equal values.
Public operatorStatic member(Vector3d to Vector3f)
Converts a double-precision vector in a single-precision vector. Needs explicit casting to help retain precision.
Public operatorStatic memberGreaterThan
Determines whether the first specified vector comes after (has superior sorting value than) the second vector.

Components evaluation priority is first X, then Y, then Z.

Public operatorStatic memberGreaterThanOrEqual
Determines whether the first specified vector comes after (has superior sorting value than) the second vector, or it is equal to it.

Components evaluation priority is first X, then Y, then Z.

Public operatorStatic memberInequality
Determines whether two vectors have different values.
Public operatorStatic memberLessThan
Determines whether the first specified vector comes before (has inferior sorting value than) the second vector.

Components evaluation priority is first X, then Y, then Z.

Public operatorStatic memberLessThanOrEqual
Determines whether the first specified vector comes before (has inferior sorting value than) the second vector, or it is equal to it.

Components evaluation priority is first X, then Y, then Z.

Public operatorStatic memberMultiply(Single, Vector3f)
Multiplies a vector by a number, having the effect of scaling it.
Public operatorStatic memberMultiply(Vector3f, Vector3f)
Multiplies two Vector3f together, returning the dot (internal) product of the two. This is not the cross product.
Public operatorStatic memberMultiply(Vector3f, Single)
Multiplies a vector by a number, having the effect of scaling it.
Public operatorStatic memberSubtraction
Subtracts the second vector from the first one.
Public operatorStatic memberUnaryNegation
Computes the opposite vector.
Top
See Also