Click or drag to resize

Dialogs Methods

The Dialogs type exposes the following members.

Methods
  NameDescription
Public methodStatic memberKillSplash
Destroy the splash screen if it is being displayed.
Public methodStatic memberCode exampleSetCustomColorDialog
Public methodStatic memberShowAboutDialog
Public methodStatic memberShowCheckListBox
Displays Rhino's check list box.
Public methodStatic memberCode exampleShowColorDialog(Color)
Display Rhino's color selection dialog.
Public methodStatic memberShowColorDialog(Color4f, Boolean)
Displays the standard modal color picker dialog for floating point colors.
Public methodStatic memberShowColorDialog(Color, Boolean, String)
Display Rhino's color selection dialog.
Public methodStatic memberShowColorDialog(IWin32Window, Color4f, Boolean) Obsolete.
Displays the standard modal color picker dialog for floating point colors.
Public methodStatic memberShowColorDialog(Object, Color4f, Boolean)
Displays the standard modal color picker dialog for floating point colors.
Public methodStatic memberShowColorDialog(Color, Boolean, String, NamedColorList)
Display Rhino's color selection dialog.
Public methodStatic memberShowColorDialog(Object, Color4f, Boolean, DialogsOnColorChangedEvent)
Displays the standard modal color picker dialog for floating point colors.
Public methodStatic memberShowColorDialog(Object, Color4f, Boolean, NamedColorList, DialogsOnColorChangedEvent)
Displays the standard modal color picker dialog for floating point colors.
Public methodStatic memberShowComboListBox
Displays Rhino's combo list box.
Public methodStatic memberShowContextMenu
Creates an ETO ContextMenu from an array of strings. Use the modes array to enable/disable menu items
Public methodStatic memberShowEditBox
Displays Rhino's string edit box.
Public methodStatic memberShowLayerMaterialDialog
Show a modal dialog to edit the material in the layer specified in layerIndices.
Public methodStatic memberShowLineTypes(String, String, RhinoDoc)
Displays Rhino's LineType list box.
Public methodStatic memberShowLineTypes(String, String, RhinoDoc, Guid)
Public methodStatic memberShowListBox(String, String, IList)
Displays Rhino's list box.
Public methodStatic memberShowListBox(String, String, IList, Object)
Displays Rhino's list box.
Public methodStatic memberShowMessage(String, String)
Same as System.Windows.Forms.MessageBox.Show but using a message box tailored to Rhino.
Public methodStatic memberShowMessage(String, String, ShowMessageButton, ShowMessageIcon)
Same as System.Windows.Forms.MessageBox.Show but using a message box tailored to Rhino.
Public methodStatic memberShowMessage(Object, String, String, ShowMessageButton, ShowMessageIcon, ShowMessageDefaultButton, ShowMessageOptions, ShowMessageMode)
Same as System.Windows.Forms.MessageBox.Show but using a message box tailored to Rhino.
Public methodStatic memberShowMultiListBox
Displays Rhino's multiple selection list box.
Public methodStatic memberShowNumberBox(String, String, Double)
Displays Rhino's number edit box.
Public methodStatic memberShowNumberBox(String, String, Double, Double, Double)
Displays Rhino's number edit box.
Public methodStatic memberShowPrintWidths(String, String)
Shows the print widths dialogs
Public methodStatic memberShowPrintWidths(String, String, Double)
Shows the print widths dialogs
Public methodStatic memberShowPropertyListBox(String, String, ListKeyValuePairString, String)
Displays Rhino's property list box.
Public methodStatic memberShowPropertyListBox(String, String, IList, IListString)
Displays Rhino's property list box.
Public methodStatic memberShowSelectLayerDialog
Displays Rhino's single layer selection dialog.
Public methodStatic memberShowSelectLinetypeDialog
Displays Rhino's single linetype selection dialog.
Public methodStatic memberShowSelectMultipleLayersDialog
Public methodStatic memberShowSunDialog
Show the modal sun dialog.
Public methodStatic memberShowTextDialog
Display a text dialog similar to the dialog used for the "What" command.
Top
See Also