Click or drag to resize

DialogsShowMessage Method (Object, String, String, ShowMessageButton, ShowMessageIcon, ShowMessageDefaultButton, ShowMessageOptions, ShowMessageMode)

Same as System.Windows.Forms.MessageBox.Show but using a message box tailored to Rhino.

Namespace:  Rhino.UI
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 6.0
Syntax
public static ShowMessageResult ShowMessage(
	Object parent,
	string message,
	string title,
	ShowMessageButton buttons,
	ShowMessageIcon icon,
	ShowMessageDefaultButton defaultButton,
	ShowMessageOptions options,
	ShowMessageMode mode
)

Parameters

parent
Type: SystemObject
Parent window
message
Type: SystemString
Message box text content.
title
Type: SystemString
Message box title text.
buttons
Type: Rhino.UIShowMessageButton
Which buttons to display in the message box.
icon
Type: Rhino.UIShowMessageIcon
Which icon to display in the message box.
defaultButton
Type: Rhino.UIShowMessageDefaultButton
Which button is the default button.
options
Type: Rhino.UIShowMessageOptions
Additional message box options.
mode
Type: Rhino.UIShowMessageMode
The modality of the message box.

Return Value

Type: ShowMessageResult
One of the ShowMessageBoxResult values.
See Also