Click or drag to resize

DialogsShowContextMenu Method

Creates an ETO ContextMenu from an array of strings. Use the modes array to enable/disable menu items

Namespace:  Rhino.UI
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public static int ShowContextMenu(
	IEnumerable<string> items,
	Point screenPoint,
	IEnumerable<int> modes
)

Parameters

items
Type: System.Collections.GenericIEnumerableString

[Missing <param name="items"/> documentation for "M:Rhino.UI.Dialogs.ShowContextMenu(System.Collections.Generic.IEnumerable{System.String},System.Drawing.Point,System.Collections.Generic.IEnumerable{System.Int32})"]

screenPoint
Type: System.DrawingPoint

[Missing <param name="screenPoint"/> documentation for "M:Rhino.UI.Dialogs.ShowContextMenu(System.Collections.Generic.IEnumerable{System.String},System.Drawing.Point,System.Collections.Generic.IEnumerable{System.Int32})"]

modes
Type: System.Collections.GenericIEnumerableInt32

[Missing <param name="modes"/> documentation for "M:Rhino.UI.Dialogs.ShowContextMenu(System.Collections.Generic.IEnumerable{System.String},System.Drawing.Point,System.Collections.Generic.IEnumerable{System.Int32})"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:Rhino.UI.Dialogs.ShowContextMenu(System.Collections.Generic.IEnumerable{System.String},System.Drawing.Point,System.Collections.Generic.IEnumerable{System.Int32})"]

See Also