Click or drag to resize

RhinoMath Methods

The RhinoMath type exposes the following members.

Methods
  NameDescription
Public methodStatic memberClamp(Double, Double, Double)
Limits a Double to be specified within an interval of two numbers, by specifying a fixed minimum and maximum.
Public methodStatic memberClamp(Int32, Int32, Int32)
Restricts a Int32 to be specified within an interval of two integers.
Public methodStatic memberCRC32(UInt32, Byte)
Advances the cyclic redundancy check value remainder given a byte array. http://en.wikipedia.org/wiki/Cyclic_redundancy_check.
Public methodStatic memberCode exampleCRC32(UInt32, Double)
Advances the cyclic redundancy check value remainder given a Double. http://en.wikipedia.org/wiki/Cyclic_redundancy_check.
Public methodStatic memberCRC32(UInt32, Int32)
Advances the cyclic redundancy check value remainder given a Int32. http://en.wikipedia.org/wiki/Cyclic_redundancy_check.
Public methodStatic memberEpsilonEquals(Double, Double, Double)
Compare two doubles for equality within some "epsilon" range
Public methodStatic memberEpsilonEquals(Single, Single, Single)
Compare to floats for equality within some "epsilon" range
Public methodStatic memberEvaluateNormal
Expert tool to evaluate surface unit normal.
Public methodStatic memberEvaluateNormalPartials
Expert tool to evaluate partial derivatives of surface unit normal.
Public methodStatic memberIntIndexToString
Portrays an Int32 index in text.
Public methodStatic memberIsValidDouble
Determines whether a Double value is valid within the RhinoCommon context.

Rhino does not use Double.NaN by convention, so this test evaluates to true if:

x is not equal to RhinoMath.UnsetValue

System.Double.IsNaN(x) evaluates to false

System.Double.IsInfinity(x) evaluates to false

Public methodStatic memberIsValidSingle
Determines whether a Single value is valid within the RhinoCommon context.

Rhino does not use Single.NaN by convention, so this test evaluates to true if:

x is not equal to RhinoMath.UnsetValue,

System.Single.IsNaN(x) evaluates to false

System.Single.IsInfinity(x) evaluates to false

Public methodStatic memberMetersPerUnit
Return number of meters per one unit of a given unit system
Public methodStatic memberParseNumber
Evaluates command line math expression.
Public methodStatic memberToDegrees
Convert an angle from radians to degrees.
Public methodStatic memberToRadians
Convert an angle from degrees to radians.
Public methodStatic memberTryParseNumber
Evaluates command line math expression.
Public methodStatic memberUnitScale(UnitSystem, UnitSystem)
Computes the scale factor for changing the measurements unit systems.
Public methodStatic memberUnitScale(UnitSystem, Double, UnitSystem, Double)
Computes the scale factor for changing the measurements unit systems.
Public methodStatic memberWrap
Limits a Double to be specified within an interval of two numbers by repeating the available interval cyclically.
Top
See Also